قامة Edit تحرير

أعلى هذه القائمة متغير بحسب المصدر المحدد وكما ترى في الصورة أعلاه فهي تأخذ نفس شكل القائمة التي تحصل عليها عند ضغطك بالزر الأيمن للفأرة على المصدر السبرايت،

هناك أربعة عناصر ثابتة في هذه القائمة وهي كالتالي:

Find Resource | بحث عن مصدر
Expand Resource Tree | فتح شجرة المصدر
Collapse Resource Tree | إغلاق شجرة المصدر
Show Object Information | عرض معلومات الكائن -عند الضغط عليها ستظهر النافذة الموجودة أدناه

وهذه النافذة تعرض لك معلومات جميع الكائنات الموجودة وتتيح لك خياران:

الأول : حفظ هذه المعلومات إلى مستند نصي.

الثاني : طباعة هذه المعلومات.

طبعا علامة P الموجودة هي لإغلاق النافذة.

الفهرس


قائمة Resources مصادر

تفيدك هذه القائمة من إضافة أنواع المصادر المختلفة وعناصر هذه القائمة كالتالي:

Create Sprite | إنشاء سبرايت ( الصورة التي تمثل الكائن سواءا ثابتة أو متحركة)
Create Sound | إنشاء صوت
Create Background | إنشاء خلفية
Create Path | إنشاء مسار
Create Script | إنشاء سيكريبت
Create Font | إنشاء خط
Create Time Line | إنشاء خط زمن
Create Object | إنشاء كائن
Create Room | إنشاء غرفة
Change Game Information | تغيير معلومات اللعبة
Change Global Game Settings | تغيير إعدادات اللعبة العالمية (العامة)
Select Extension Packages | اختيار حزم التوسيع (توسيع إمكانات القيم ميكر)


قائمة سيكريبتات

قامة Scripts سيكريبتات:

هذه القائمة كما يبين اسمها مختصة بالسيكريبتات فعن طريقها يمكنك عمل التالي

Import Scripts | جلب سيكربتات لإستخدامها في لعبتك
Exp ort All Scripts | تصدير كافة السيكريبتات (لتتمكن مثلا من استخدامها في لعبة أخرى - عن طريق الأمر السابق-)
Show Built-in Variables | عرض المتغيرات الأساسية في القيم ميكر -يمكنك إنشاء متغيراتك الخاصة بك-
Show Built-in Functions | عرض الدوال الأساسية في القيم ميكر - يمكنك إنشاء دوالك الخاصة بك-
Show Extension Functions | عرض دوال حزمة التوسيع
Show Constants | عرض الثوابت
Show Resource Names | عرض أسماء المصادر - الموجودة في لعبتك -
Search in Scripts | بحث عن نص في جميع السيكريبتات
Check Resource Names | فحص أسماء المصادر
Check All Scripts | فحص جميع السيكريبتات

هذه نتيجة فحص أسماء المصادر وهي تبين بأن هناك مصدري سبرايت لهما نفس الإسم وإن هناك كائن أيضا له نفس إسمهما - يمكنك النقر على أي سطر ليفتح لك خصائص المصدر المشار إليه حيث يمكنك تعديل اسمه.


قامة run تشغيل

قائمة تشغيل اللعبة وهي تحتوي على عنصرين وإليك معنى كل عنصر:

Run normally | تشغيل اللعبة
Run in Debug mode | تشغيل اللعبة في وضع التصحيح - يمكنك مراقبة اللعبة والتعديل عليها أثناء عملها ومراقبة ما قد يحدث من أخطاء

ستظهر هذه النافذة بجوار لعبتك عند اختيارك لتشغيل لعبتك في وضع التصحيح وكما ترى فهذه النافذة تحتوي على ثلاث قوائم وإليك هذه القوائم مع معاني عناصر كل قائمة

قائمة التشغيل Run

Run | تشغيل - طبعا يتم تفعيل هذا الأمر عند اختيار أمر الإيقاف المؤقت -
Pause | إيقاف مؤقت للعبة يمكنك إنهاؤه باختيار أمر التشغيل
Step | يتم أخذ خطوة للأمام - طبعا يتم تفعيل هذا الأمر عند اختيار أمر الإيقاف المؤقت -
Restart | إعادة تشغيل اللعبة
Stop | إيقاف اللعبة و الخروج من وضع التصحيح

قائمة المراقبة Watch

Add | إضافة متغير لمراقبة قيمته
Change | تغيير المتغير التي تمت إضافته عن طريق الأمر السابق
Delete | حذف المتغير
Clear | حذف جميع المتغيرات (جميع هذه الأحداث من إضافة وحذف تختص بقائمة المراقبة )
Load | تحميل من ملف -اسم متغير تم حفظه عن طريق الأمر التالي
Save | حفظ اسم المتغير

قائمة الأدوات Tools:

Execute Code | تنفيذ كود
Set Speed | ضبط سرعة الغرفة
Show Global Variables | عرض المتغيرات العالمية (العامة)
Show Local Variables | عرض المتغيرات المحلية (الخاصة)
Show Instances | عرض نسخ الكائنات
Show Messages | عرض الرسائل - رسائل الأخطاء -

عند اختيارك لعرض المتغيرات العالمية(العامة) ستظهر نافذة شبيهة بالنافذة التالية حيث يمكنك مراقبة تغير قيم هذه المتغيرات بالإضافة إلى إمكانية حفظها إلى ملف:


قائمة window نافذة

هذه القائمة تكاد تكون موجودة في معظم برامج الويندوز ولا أظنك ستجد صعوبة في فهمها وهي تحتوى على ثلاثة عناصر وإليك معنى كل عنصر:

Cascade | ترتيب النوافذ بشكل انسيابي
Arrange Icons | ترتيب الأيقونات
Close All | إغلاق كافة النوافذ (طبعا النوافذ الموجودة داخل نافذة القيم ميكر)


قامة Help مساعدة

قائمة المساعدة أو التعليمات وضعت هذه القائمة لمساعدتك وإعطائك التعليمات المناسبة لتتعلم هذا البرنامج وعناصرها كالتالي:

Contents | المحتويات(ملف التعليمات المرفق مع البرنامج)
Extension Packages | عند تنصيبك لأحد حزم التوسيع فإن هذه القائمة ستعرض ملفات تعليمات كل حزمة لمعرفة دوال ومتغيرات هذه الحزمة
Online Help | المساعدة عن طريق الإنترنت -سينقلك هذا الأمر إلى موقع http://wiki.yoyogames.com/help -
Book | كتاب القيم ميكر -لم أجربه ولا أعلم هل هو مجاني أم لا ولكني أعتقد بأنه غير مجاني
Website | موقع القيم ميكر
Forums | منتديات القيم ميكر
About Game Maker | حول برنامج القيم ميكر


Game Maker 7 باللغة العربية

الأفعال Actions:

الأفعال هي ما يفعله الكائن أوهو تصرف الكائن عند حدوث حدث معين وهناك مكتبات الأفعال (Action Libraries ) موجودة في الدليل lib داخل مجلد البرنامج والتي تسهل لك تحديد فعل محدد عند حدوث أحد الأحداث يوجد مع القيم ميكر سبع مكتبات أساسية ويمكنك أن تضيف المزيد من المكتبات حسب رغبتك وأيضا يمكنك صنع مكتبات أفعال بواسطة برنامج اسمه Library_Maker (صانع المكتبة) ولكن يجب عليك إتقان لغة برمجة القيم ميكر حتى تتمكن من صنع هذه المكتبات:

والآن دعنا نبدأ شرح هذه المكتبات الأساسية:

مكتبة move : الحركة:

ملاحظة:عند تحديد نسبي فسيتم زيادة السرعة بنفس المقدار الذي حددته لها

عند تحديد نسبي فإن المكان سيكون مكان الكائن مضافا إليه الرقم المحدد في x و y

ملاحظة:عند تحديد نسبي فسيتم زيادة السرعة بنفس المقدار الذي حددته لها

ملاحظة:عند تحديد نسبي فسيتم زيادة السرعة بنفس المقدار الذي حددته لها

ملاحظة:عند تحديد نسبي فسيتم تحديد الإتجاه بالنسبة للكائن . بشكل افتراضي يكون الكائن متجه إلى الإتجاه 0 والذي يكون إلى يمينك عزيزي القأرئ

ملاحظة: في الحقيقة لا يوجد هناك أي احتكاك ولكن المقصود بهذا الفعل هو محاكاة فيما لو كان هناك احتكاك طبيعي فكلما زاد الاحتكاك فإن الكائن ستقل سرعته بشكل سريع إلى أن يتوقف

سؤال: خمن عزيزي القارئ وظيفة مربع الإختيار نسبي؟

ملاحظة: عند تحديد نسبي سيتم إضافة الرقم الذي كتبته ليعبر عن مكان الكائن في المسار إلى مكانه الحالي.

يمكنك من الآن فصاعدا أن تتنبأ بعمل مربع الخيار نسبي.

المكتبة الرئيسية1 :main1:

 | راجع أسماء التأثيرات في الفعل السابق
 | راجع أسماء التأثيرات في فعل الانتقال إلى الغرفة السابقة
 | راجع أسماء التأثيرات في فعل الانتقال إلى الغرفة السابقة
التأكد من وجود غرفة قبل الغرفة الحالية وفي حالة وجودها ينفذ الفعل أو مجموعة الأفعال التالية |
التأكد من وجود غرفة قبل الغرفة الحالية وفي حالة وجودها ينفذ الفعل أو مجموعة الأفعال التالية |

المكتبة الرئيسية2:main2 :

عرض معلومات اللعبة |
 | يدعم القيم ميكر تشغيل الصيغ التالية: avi و wmv و mpg ولكن بتجنب الكودكس "codecs" الخاصة
إعادة تشغيل اللعبة |
إنهاء اللعبة |

مكتبة التحكم : control:

 | ملاحظة: not تعني تنفيذ الفعل أو مجموعة الأفعال التالية في حالة وجود تصادم أي أنها تعكس عمل الفعل
بداية مجموعة أفعال |
في حالة الأفعال الشرطية يوجد شرط إذا تحقق تنفذ الأفعال وهذا الفعل Else يسمح لك بإدراج أفعال تنفذ في حالة عدم تحقق الشط |
عدم تنفيذ جميع الأفعال التي تلي هذا الفعل |
نهاية مجموعة أفعال |
إذا كان الكائن له أب (parent) فإن هذا الفعل يستدعي الحدث المتوافق |

مكتبة الدرجة : score:

مسح جدول الدرجات العالية |
 | لون الشكل الخلفي(خلفية الشكل ) لون الشكل الأمامي (لون الشكل)

المكتبة الإضافية: extra:

تدمير نظام الجزيئات لتحرير الذاكرة المستخدمة لها | تستخدم الجزيئات ذاكرة كبيرة لذا لا تنسى استدعاء هذا الفعل حال انتهائك منها
إزالة الجزيئات المرئية حاليا ولكن لا يدمر الإيميتر لذا ففي حالة كون الجزيئات تنشأ بشكل مستمر فإن هذا الفعل لا يوقفها نهائيا |
 | تشغيل مسارات صوتية من قرص مضغوط
إيقاف المسارات الجاري قرائتها |
إيقاف المسارات الجاري قرائتها مؤقتا |
تشغيل المسارات التي تم إيقافها مؤقتا |
التأكد من وجود قرص في قارئ الأقراص الافتراضي ومن ثم تنفيذ الفعل أو مجموعة الأفعال التالية |
التأكد من تشغيل قرص في قارئ الأقراص الافتراضي ومن ثم تنفيذ الفعل أو مجموعة الأفعال التالية |

مكتبة الرسم: draw:


النافذة الرئيسية

نافذة القيم ميكر الرئيسية:

عزيزي القارئ:

هذه هي نافذة البرنامج الرئيسية وهي كما ترى بسيطة وغاية في السهولة وفي صفحات هذا الكتاب سأحاول شرح كل قوائم ونوافذ القيم ميكر لتصبح إن شاء الله خلال أيام - أو أسابيع :) - محترف قيم ميكر.